Prism Mobile Device Requirements

Avatar
Paul Schneider
Follow

 

PRISM Mobile Device Requirements

Platforms that are supported for current Prism Mobile app versions. 

  • The Prism Mobile app currently requires users to have a device with an OS that is:
    • Apple
      • Recommended - Latest iOS (16)
      • Minimum or higher - PMO iOS - 14
      • Minimum or higher - Tenant iOS - 14
    • Android
      • Recommended - Latest Android OS (13)
      • Minimum or higher - PMO Android - 8
      • Minimum or higher - Tenant Android - 7
  • iOS users should download the Prism Mobile app from the App Store
  • Android users should download the Prism Mobile app from the Google Playstore
Powered by Zendesk